Windcave Degraded Performance
Incident Report for Flash
Resolved
We have been notified that the Windcave performance issues have been resolved.
Posted May 04, 2024 - 12:09 CDT
Investigating
We have been notified by our EMV payment gateway partner Windcave that they are currently experiencing severely degraded performance. This may result in delayed or failed payments for locations using Windcave for EMV payment processing. We will continue to update this page as more information comes in. Updates can also be found at status.windcave.com.
Posted May 04, 2024 - 11:26 CDT
This incident affected: FLASH Products (FlashValet, FlashPARCS).